[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
> At 03:29 PM 12/15/96 -0800, Bill Frantz wrote:
> >One possibility would be to call it "Final". (This name makes more sense
> >if the value is boolean rather than integer.) If the value is integer, it
> >could be called something like MaxChainLength. (You can see I've been
> >writing far too much Java code. :-) )
> I see no problem with either change. This leaves the question of boolean
> vs. integer. I can imagine a use for small integer values (e.g., my
> intention is to let him delegate to a temporary key of his own but not to a
> world of users) -- but back to your truth-in-advertising desire, the boolean
> makes a lot more sense.
> So - I think I'd opt for the boolean.
> How do others feel?
> - Carl
I've always felt that greater than one and less than infinity was
arbitrary enough to be sort of silly, so doing it as a boolean doesn't
bother me a lot. If I give someone the ability to delegate, I am
trusting them to act in my interest, whether once or more than once. I
sometimes feel that one is special enough to allow it, but not strongly
enough to argue for it, nor do I have any real argument that way.
Brian Thomas - Distributed Systems Architect firstname.lastname@example.org
Southwestern Bell email@example.com
One Bell Center, Room 34G3 Tel: 314 235 3141
St. Louis, MO 63101 Fax: 314 235 0162